ImportError: No module named layman.config

Today, when I tried to sync the portage overlays on my gentoo linux boxes, I got the error:

ImportError: No module named layman.config

The recent update from python-2.5 to python-2.6 has broken several applications. This issue was solved by running python-updater, which re-emerges all broken python packages. Besides from layman not working, the python upgrade may cause several other problems in portage and in the whole system. Thus just be sure to run python-updater after the python-upgrade.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...