util-vserver-0.30.216_pre2841 vserver startup fails

A while ago during regular upgrades my gentoo box serving as test environment for vservers updated to util-vserver-0.30.216_pre2841. Some weeks later, when I restarted the box I recognized that it could not start any vserver:

# vserver ubuntu start
vcontext: pivot_root(): Invalid argument

An error occured while executing the vserver startup sequence; when
there are no other messages, it is very likely that the init-script
(/etc/init.d/rc 3) failed.

Common causes are:
* /etc/rc.d/rc on Fedora Core 1 and RH9 fails always; the ‘apt-rpm’ build
method knows how to deal with this, but on existing installations,
appending ‘true’ to this file will help.

The box is running vserver-sources kernel 2.6.28-vs2.3.0.36.4-gentoo #2 SMP.

Since I did not find any useful information regarding his error in the web I tried downgrading to util-vserver-0.30.215-r3. For gentoo users this is accomplished by including

>sys-cluster/util-vserver-0.30.215-r3

in /etc/portage/package.mask. Afterwards everything reverted to normality.

If you also experience the “pivot_root(): Invalid argument” error, try downgrading util-vserver and hope for the best 😉

regards

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...