Upgrade to compiz-fusion-0.8.6

Today, when I ran the regular update of my gentoo systems there was an update for compiz-fusion in portage. The compiz update did not work out of the box on my x8_64 systems, missing keywords, blocking packages, etc.

Here is the way I got it to work. The procedure is similar to the one I described in upgrade-to-compiz-fusion-0.82.

emerge -uND world

!!! All ebuilds that could satisfy “>=x11-plugins/compiz-plugins-main-0.8.6” have been masked.
!!! One of the following masked packages is required to complete your request:
– x11-plugins/compiz-plugins-main-0.8.6 (masked by: ~amd64 keyword)

Add to /etc/portage/package.keywords:

=x11-plugins/compiz-plugins-main-0.8.6 **
=x11-plugins/compiz-plugins-unsupported-0.8.6 **
=x11-plugins/compiz-plugins-extra-0.8.6 **
=x11-plugins/compiz-plugins-unsupported-0.8.4-r1 **

the last line is there just because I don´t know if there will be a newer version of compiz-plugins-unsuported or not.

emerge compiz-fusion

[blocks B ] x11-plugins/compiz-fusion-plugins-extra (“x11-plugins/compiz-fusion-plugins-extra” is blocking x11-plugins/compiz-plugins-extra-0.8.4-r1)
[blocks B ] x11-plugins/compiz-fusion-plugins-main (“x11-plugins/compiz-fusion-plugins-main” is blocking x11-plugins/compiz-plugins-main-0.8.4-r1)

emerge -C compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-fusion-plugins-unsupported

emerge compiz-fusion

Afterwards I had a working compiz-fusion-0.8.6.

regards

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...