New version of SIV – the Stereoscopic Image Viewer ahead

Last year I published the first release of my stereoscopic image viewer, SIV here. At the time it was the first viewer for Linux supporting jps files and quad buffered stereo. As far as I know it is still the only one with support for the headtracking of the VR920 head mounted display. Currently I am working on a new and better version which will have the following additional features:

  • native support for the MPO file format (used by Fujifilm stereo cameras)
  • adjustments for
    -parallax
    -brightness
    -contrast
    -gamma
  • Improved OSD
  • Filters
    -black/white
    -sepia

In the current development stage most of the features are basically working so expect the new version of the viewer to be released soon. I hope to get it ready for Christmas, for those of you who have their new 3D camera under the Christmas tree.

Stay tuned for updates

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

FlightGear with quad buffered stereo

With my upcoming new headtracking driver for the vusix vr920 hmd it is likely that I manage to get the famous flight simulator FlightGear to work with it. This led me again to the problem that FlightGear does not work in quad buffered stereo, as  I described in my comment to FlightGEAR 2.0.0 on GENTOO.

One expects to enable stereoscopic mode in FlightGear starting it with the following line:

export OSG_STEREO_MODE=QUAD_BUFFER;export OSG_STEREO=ON; fgfs

When starting flightgear this way, one gets the following console output and no stereoscopic view:

Warning: detected OpenGL error ‘invalid operation’ after RenderBin::draw(,)

Getting FlightGear to work with quad-buffered stereo

Doing some code analysis in OpenSceneGraph-2.8.0 I discovered the following lines of code in View.cpp:

osg::DisplaySettings* ds = osg::DisplaySettings::instance();
if (ds->getStereo())
{
switch(ds->getStereoMode())
{
case(osg::DisplaySettings::QUAD_BUFFER): traits->quadBufferStereo = true; break;
case(osg::DisplaySettings::VERTICAL_INTERLACE):
case(osg::DisplaySettings::CHECKERBOARD):
case(osg::DisplaySettings::HORIZONTAL_INTERLACE): traits->stencil = 8; break;
default: break;
}
}

It seems that the stereo context in FlightGear does not get initialized properly in WindowBuilder::makeDefaultTraits(bool stencil). Thus these lines have to be added to WindowBuilder.cxx. For convenience here is the patch against  FlightGear-2.0.0: flightgear-2.0.0-stereoscopic.patch (1547)

Perhaps some nice FlightGear developer can include this into upstream code. You have to use a professional graphics board that supports quad buffered stereo, like a NVIDIA Quadro FX or a Ati FireGL and proper display hardware, like shutter glasses, a HMD or a stereoscopic projection system, to benefit from it.

Problems remaining

When using the quad buffered stereo mode in flightgear there occur some graphics errors. These are not very annoying, but they are there. Some cockpit controls and other scene details contain yellow lines, like a wireframe,  which are not there when starting FlightGear in “normal” display mode. I suspect this to be another bug in FlightGear, which has still to be located. See the screenshots below for details. The problematic parts of the scenes are marked red. Especially the night pictures show the problem. This problem does not only exist in quad buffered stereo mode, but also in other stereo modes like HORIZONTAL_SPLIT.

flightgear_1

FlightGear by day, quad-buffered stereo, with errors

flightgear_2

FlightGgear by day, no stereo, without errors

flightgear_3

FlightGear by night, quad-buffered stereo, with errors

flightgear_4

FlightGear by night, no stereo, without errors

The Gentoo way

For gentoo users here is my overlay including the modified ebuild: flightgear-2.0.0-stereoscopic_overlay.tar.gz (1387) Download the modified overlay (including the patches) and extract it in /usr/local/portage. Be sure to include the following line in your /etc/make.conf:

PORTDIR_OVERLAY=”/usr/local/portage”

Then emerge flightgear and enjoy it in three dimensions.

Have fun

Jürgen

Tool to increase your alexa rank instantly

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

New version of the vr920 headtracking driver coming soon

Last year I published the first version of my linux headtracking driver for the VR920 HMD here. Currently I am working on a new driver version which will have the following additional features:

  • Multiple Protocols:
    -UDP multicast (as before)
    -UDP unicast (for flightgear connection and perhaps more)
    -mouse emulation (via uinput)
    -joystick emulation (via uinput)
    -character device for direct angle readings (via cuse, will
    require a kernel >= 2.6.31)
  • Inverting of axes (to have moving the head up making the mouse pointer up or down, depending on needs)
  • Better filtering algorithm (more stable headtracking)
  • Scaling of data (i.e. to match screen size with mouse mode)
  • Customisable delay between sensor readings
  • User interface separated from the driver

With the upcoming MPX and the mouse emulation it should be possible to control the visible viewport by turning around the head. Controlling the view for games or other software that do not natively support headtracking should also be possible with the emulation.

In the current development stage most of the features are basically working so expect the new driver to be released soon.

Stay tuned for updates

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

Petition for Gimp

Today I found this petition for Gimp. Have a look and support gimp. It seems that gimp should be removed from the next ubuntu release. There for have a look at Bring Out The Gimp petition. Below is a copy from this site. Now Sign the Petition and stay tuned.

To:  GNU/Linux major distributions

We, the undersigned, kindly ask all major distributions not to cripple their release CD’s by removing important applications like OpenOffice.org, GIMP, and others.

These applications may have their set of problems. Granted. Let’s work on them as well.

However, removing such important applications in order to save space for any “current trendy application” just because said application depends on bloated, problematic and polemic runtime environments reveals a worrysome mindset: form over substance.

If the functionality said application provides, is also provided by another application which is far leaner, then please fix the problems with the leaner applications rather than removing important applications such as The GIMP.

Sincerely,

The Undersigned

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

java3d ebuild for gentoo

The java3d ebuilds in the gentoo portage tree are very outdated, and didn’t even work for me anymore. So I wanted to install a newer version of java3d. This resulted in the updated ebuild you can download from here:

sun-java3d-bin-1.5.2.ebuild (867)

I tried the ebuild together with sun-jdk-1.6.0.13 on x86_64 gentoo linux, but it schould also work on i586.

To use it just create the directory structure

mkdir -p /usr/local/portage/dev-java/sun-java3d-bin/

and copy the new ebuild to that directory. Then run

ebuild /usr/local/portage/dev-java/sun-java3d-bin/sun-java3d-bin-1.5.2.ebuild digest

Be sure to include the following line in your /etc/make.conf:

PORTDIR_OVERLAY=”/usr/local/portage”

Then just emerge sun-java3d.

emerge /usr/local/portage/dev-java/sun-java3d-bin/sun-java3d-bin-1.5.2.ebuild

The ebuild creates some symlinks in your VM’s directory, so if you switch the browser plugin or the entire VM you have to reemerge sun-java3d-bin. To have the library ready to use you also have to add the following lines to your /etc/profile:

if [ “$CLASSPATH” = “” ] ; then
CLASSPATH=”/usr/share/sun-java3d-bin/lib/vecmath.jar:/usr/share/sun-java3d-bin/lib/j3dutils.jar:/usr/share/sun-java3d-bin/lib/j3dcore.jar”
else
CLASSPATH=”${CLASSPATH}:/usr/share/sun-java3d-bin/lib/vecmath.jar:/usr/share/sun-java3d-bin/lib/j3dutils.jar:/usr/share/sun-java3d-bin/lib/j3dcore.jar”
fi
export CLASSPATH

if [ “$LD_LIBRARY_PATH” = “” ] ; then
LD_LIBRARY_PATH=”/usr/lib/sun-java3d-bin/”
else
LD_LIBRARY_PATH=”${LD_LIBRARY_PATH}:/usr/lib/sun-java3d-bin/”
fi
export LD_LIBRARY_PATH

To have the changes in effect logout and login again.

If you want to have java3d useable in firefox you have to modify the line:

export LD_LIBRARY_PATH=”/usr/lib64/mozilla-firefox”

in your /usr/bin/firefox to:

export LD_LIBRARY_PATH=”/usr/lib64/mozilla-firefox”:$LD_LIBRARY_PATH

Otherwise you will end up getting unstatisfied link errors since the j3d library cannot be loaded.

Finally you can test if your java3d works on Testseite für Java und Java3D – VS-C. If you are working in a multiheaded environment, this java3d version may only work on the first display. So, if you experience problems just place your browser on the first head.

Have Fun

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...

osgocean ebuild for gentoo

I just recognized the osgocean release on the osg mailing-list. Osgocean is a library that one can use to render water effects in a very realistic way. It was used to generate the above and below water effects in the VENUS project. For more information on the osgocean project see: osgocean You can see how realistic it looks if you watch the youtube video below.

It looked very interesting, so I decided to try it out. To do so I wrote two ebuilds, one for osgocean and one for  fftss, the fast fourier transformation library it depends on. Both are available in following archive: osgocean overlay (1157)

Extract the archive to your portage overlay.

# mkdir /usr/local/portage/
# cd /usr/local/portage/
# unzip osgocean_overlay.zip

Be sure that PORTDIR_OVERLAY=”/usr/local/portage” is included in your /etc/make.conf, then you can emerge it:

#emerge osgocean

For this you need to have the OpenSceneGraph library installed. Detailed Instructions on how to build OpenSceneGraph on gentoo can be found on PlopByte.

Since openscenegraph is now in the main portage tree I have updated the ebuild dependencies today (31/08/2009) to either media-gfx/openscenegraph or dev-games/openscenegraph.

Updated ebuild is now available here: osgocean-1.0.1.ebuild (1100) Just copy it to /usr/local/portage/media-gfx/osgocean/ after extractingosgocean_overlay.zip like described before and run:

ebuild /usr/local/portage/media-gfx/osgocean/osgocean-1.0.1.ebuild digest

Best regards

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

nvidia-drivers-180.60 is working !!!

After I have tested the nvidia-drivers-185.18.08 beta I searched the web for a new one and I found it yesterday on nvnews.net. This version seems to run well on my Dell M4300. For all using Gentoo I  made an ebuild:ebuild:nvidia-drivers (993)

# mkdir /usr/local/portage/
# cd /usr/local/portage/
# tar -xpvf nv-portage.tar

Be sure that PORTDIR_OVERLAY=”/usr/local/portage” is in your /etc/make.conf, then you can emerge it:
# ACCEPT_KEYWORDS=”~amd64″ emerge =nvidia-drivers-180.60 -1

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...