stereoscopic mplayer-1.1-r1

Kamakailang mga bagong mplayer-1.1-r1 ebuild lumitaw sa Portage. Sa artikulong stereoscopic mplayer-1.0_rc4_p20110322 ibinigay ko ang isang binagong patch para stereoscopic suporta sa mplayer-1.0_rc4_p20110322. Patch na ito ay hindi gumagana gamit ang mga kasalukuyang bersyon na ngayon. Gayunpaman, tanging ang isang menor-aayos ay kinakailangan. Upang gamitin ang bagong patch, i-download lamang ito mula dito: mplayer-stereoscopic-1.1-r1.patch (615) at kopyahin ito sa:

/etc/portage/patches/media-video/mplayer-1.1-r1/

Pagkatapos lumabas mplayer at maglaro ng stereoscopic mga pelikula gamit ang:

mplayer -vo gl2: stereo some_movie_file.avi

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...

Flightgear-2.8.0 na may Quad buffered stereo

 Flightgear 2.8.0 with quad buffered stereo

Sa artikulong Flightgear may Quad buffered stereo ko pa nakasulat tungkol sa kung paano makakuha ng Quad buffered stereo upang gumana sa mga sikat na flight simulator FlightGear . Kamakailang FlightGear-2.8.0 ay inilabas. Ang problema sa Quad buffered stereo nagpatuloy pa rin sa FlightGear-2.8.0.

Inaasahan ng isa upang paganahin stereoscopic mode sa FlightGear nagsisimula ito sa mga sumusunod na linya:

pag-export OSG_STEREO_MODE = QUAD_BUFFER; export OSG_STEREO = SA; fgfs

Kapag nagsisimula flightgear ganitong paraan, ay makakakuha ng isa sa mga sumusunod na console output at hindi stereoscopic view:

Babala: Nakakita OpenGL error na 'hindi wastong operasyon' pagkatapos RenderBin :: mabubunot (,)

Pagkuha ng FlightGear upang gumana sa Quad-buffered stereo

Ang dahilan para sa mensahe sa itaas error at ang mga nagresultang sirang stereo mode ay, na ang stereo konteksto ay hindi makakuha ng nasimulan nang maayos. Ang mga detalye ay inilarawan dito: Flightgear may Quad buffered stereo . Sa kasamaang palad ang patch ipinanukalang ako sa nabanggit post ay hindi gumagana para sa flightgear-2.8.0. Gayunpaman, ang magandang balita ay, ito lamang ang kinakailangan ng isang bahagyang pagbabago, ang WindowBuilder.cxx file hindi na sabihin sa src / Main, ngunit sa directory / src Viewer. Maaari mong i-download ang bagong patch mula dito: flightgear-2.8.0-stereoscopic.patch (761)

Sana nakakahanap ng mga patch ng paraan sa susunod na release flightgear.

Gaya ng dati para sa Quad buffered stereo, kailangan mong gumamit ng isang propesyonal na graphics board na sumusuporta sa Quad buffered stereo, tulad ng isang NVIDIA Quadro FX o isang Ati FireGL at tamang display hardware, tulad ng shutter baso, isang HMD o isang stereoscopic projection system, upang makinabang mula sa ito. Upang gamitin ang Quad buffered stereo mode pagsisimula flightgear sa kapaligiran variable na binanggit sa itaas. Pagkatapos marahil mayroon kang upang paganahin ang Quad buffered stereo mode sa pamamagitan ng pagpili ng stereoscopic View Opsyon Item sa menu ng View.

Ang Gentoo paraan

Para sa mga gumagamit gentoo ko pa nakalikha ng isang overlay. Tulad ng nakaraang isa ito ay naglalaman ng mga patch at binagong ebuilds para sa flightgear may gumaganang suporta Quad buffer. Maaari kang makakuha ng overlay mula dito: flightgear-2.8.0 overlay (671) I-download ang overlay at kunin ito sa / usr / lokal / Portage. Maging sigurado na isama ang sumusunod na linya sa iyong /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / lokal / Portage"

Pagkatapos ay lumabas flightgear at tangkilikin ito sa tatlong dimensyon.

Magpakasaya

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...

glsldevil binaries

Tungkol sa isang taon ang nakalipas ay nagsulat ako tungkol sa OpenGL / GLSL debugger glsldevil sa artikulong gentoo ebuild para sa glsldevil-1.1.5 at ibinigay ng gentoo ebuild para dito. Sa kasamaang palad ay tila hindi na ngayon magagamit mula sa web pahina ng Unibersidad ng Stuttgart (glsldevil http://cumbia.informatik.uni-stuttgart.de/glsldevil/ ), na-render ang ebuild walang silbi.

I-edit 29/5/2012: Ang orihinal na pag-download site ng Unibersidad ng Stuttgart ay magagamit muli.

Dahil ang lisensya ng glsldevil Pinahihintulutan ng muling pamamahagi, nagpasya kong i-upload ang aking lokal na kopya, upang gumawa ng glsldevil magagamit para sa pampublikong muli. Sa kasamaang palad kasama lamang ito ang binaries Linux (32bit at 64bit) at hindi rin binaries Windows o ang source code.

Maaari mong i-download ang binaries Linux mula dito: glsldevil-1.1.5.tar.gz (790)

Para sa paggamit sa ebuild, kopyahin lamang ang file sa / usr / Portage / distfiles /.

bumabati
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 boto, average: 5.00 mula sa 5)
Loading ... Naglo-load ...

NVIDIA-driver-295.17 na malutas ang problema itim na screen

Paggamit ng NVIDIA linux driver mula sa bersyon 270.X sa 275.X na may ilang mga graphics board, sa halimbawa ng Quadro FX 350M na kung saan ay binuo sa Dell katumpakan M65 notebook, nagresulta sa isang itim na screen o window para sa OpenGL application. Kahit glxgears ginawa lamang output ng itim na window. Ang problema ay tinalakay sa forums.opensuse.org . Ang isang downgrade sa isang mas mababang driver ng bersyon, sa halimbawa ng bersyon 260.X mga driver ay hindi mailalapat ngayon, dahil ang mga driver ay tuldok bumuo laban sa isang kamakailang linux-3 ng kernel. Ang isang pag-upgrade sa mas bagong mga driver rin ay hindi posible, dahil ang driver bersyon mula 285.X upang 295.10 Hindi gumana sa lahat para sa graphics board. Kamakailan bersyon 295.17 ng driver nvidias beta ay naging available, na malulutas nito ang isyu na ito. I-download ang mga link ay magagamit sa nvnews.net .

Para sa mga gumagamit gentoo binagong ko ang NVIDIA-driver ebuild para sa 295.17 driver. Maaari mong i-download ang aking binagong overlay, NVIDIA-driver-295.17.tar.gz (364) at extract ito sa / usr / lokal / Portage. Maging sigurado na isama ang sumusunod na linya sa iyong /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / lokal / Portage"

Pagkatapos maaari mong lumabas nvdidia-driver-295.17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...

Flightgear-2.4.0 na may Quad buffered stereo

 Flightgear 2.4.0 with quad buffered stereo

Sa post Flightgear may Quad buffered stereo ko na nakasulat tungkol sa kung paano makakuha ng Quad buffered stereo upang gumana sa mga sikat na flight simulator FlightGear . Kamakailang FlightGear-2.4.0 ay inilabas. Ang problema sa Quad buffered stereo nagpatuloy pa rin sa FlightGear-2.4.0.

Inaasahan ng isa upang paganahin stereoscopic mode sa FlightGear nagsisimula ito sa mga sumusunod na linya:

pag-export OSG_STEREO_MODE = QUAD_BUFFER; export OSG_STEREO = SA; fgfs

Kapag nagsisimula flightgear ganitong paraan, ay makakakuha ng isa sa mga sumusunod na console output at hindi stereoscopic view:

Babala: Nakakita OpenGL error na 'hindi wastong operasyon' pagkatapos RenderBin :: mabubunot (,)

Pagkuha ng FlightGear upang gumana sa Quad-buffered stereo

Ang dahilan para sa mensahe sa itaas error at ang mga nagresultang sirang stereo mode ay, na ang stereo konteksto ay hindi makakuha ng nasimulan nang maayos. Ang mga detalye ay inilarawan dito: Flightgear may Quad buffered stereo . Gayunman, ang mabuting balita ay, na ang ipinanukalang mga patch ko sa nabanggit post, gumagana pa rin sa FlightGear-2.4.0. Maaari mong i-download ang patch mula dito: flightgear-2.0.0-stereoscopic.patch (805)

Gaya ng dati para sa Quad buffered stereo, kailangan mong gumamit ng isang propesyonal na graphics board na sumusuporta sa Quad buffered stereo, tulad ng isang NVIDIA Quadro FX o isang Ati FireGL at tamang display hardware, tulad ng shutter baso, isang HMD o isang stereoscopic projection system, upang makinabang mula sa ito. Upang gamitin ang Quad buffered stereo mode pagsisimula flightgear sa kapaligiran variable na binanggit sa itaas. Pagkatapos marahil mayroon kang upang paganahin ang Quad buffered stereo mode sa pamamagitan ng pagpili ng stereoscopic View Opsyon Item sa menu ng View.

Gamit ang nakaraang bersyon, kapag ginagamit ang Quad buffered stereo mode sa flightgear, may naganap na ilang mga error sa graphics. Ang ilang mga kontrol cockpit at iba pang mga detalye eksena na nilalaman dilaw na mga linya, tulad ng isang wireframe, na kung saan ay hindi doon kapag nagsisimula FlightGear sa "normal" na mode display. Ang mga problemang ito tila wala na sa Flightgear-2.4.0. Hindi bababa sa hindi ko mapansin ang mga ito.

Ang Gentoo paraan

Para sa mga gumagamit gentoo ko pa nakalikha ng isang overlay. Tulad ng nakaraang isa ito ay naglalaman ng mga patch at binagong ebuilds para sa flightgear may gumaganang suporta Quad buffer. Maaari kang makakuha ng overlay mula dito: flightgear-2.4.0 overlay (374) I-download ang overlay at kunin ito sa / usr / lokal / Portage. Maging sigurado na isama ang sumusunod na linya sa iyong /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / lokal / Portage"

Pagkatapos ay lumabas flightgear at tangkilikin ito sa tatlong dimensyon.

Magpakasaya

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...

stereoscopic mplayer-1.0_rc4_p20110322

Kahapon ang bagong mplayer-1.0_rc4_p20110322 ebuild lumitaw sa Portage. Sa post stereoscopic mplayer muli ang bahagi 2 ibinigay ko ang isang binagong patch para stereoscopic suporta sa mplayer-1.0_rc4_p20101114. Gumagana pa rin ang patch na ito gamit ang mga kasalukuyang bersyon. Upang gamitin ito, i-download lamang ang patch mula doon at kopyahin ito sa:

/etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1/

pagkatapos lumabas mplayer at maglaro ng stereoscopic mga pelikula gamit ang

mplayer -vo gl2: stereo some_movie_file.avi

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...

bino-1.0 ebuild para sa gentoo

Kamakailan ay nagsulat ako tungkol sa bino , isang stereoscopic video player na may kapaki-pakinabang linux at Sinusuportahan din ng Quad buffered stereo. Sa samantala ang unang stable na bersyon 1.0 na inilabas. Pangunahing tampok nito ay:

  • Suporta para sa 2D at stereoscopic video na 3D sa isang malawak na iba't-ibang mga format ng pag-input at stereo mga layout.
  • Suporta para sa maraming mga 3D mga pamamaraan output, kabilang ang mga baso anaglyph, baso shutter, autostereoscopic ipinapakita, 3D na mga hanay ng TV, at ipinamamahagi multi-display installation tulad ng powerwalls o Virtual Reality mga pag-install.

Ang Gentoo paraan

Para sa mga gumagamit gentoo dito ay ang aking overlay kabilang ang ebuild: bino-1.0_overlay.tar.gz (597) I-download ang overlay at kunin ito sa / usr / lokal / Portage. Maging sigurado na isama ang sumusunod na linya sa iyong /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / lokal / Portage"

Pagkatapos ay lumabas bino at magsaya sa panonood ng iyong mga 3d na pelikula.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Walang Ratings Pa)
Loading ... Naglo-load ...
2011/5/4

mygnu impormasyon

blog roll

Impormasyon ng site

Trans lator

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag