stereoskopisk mplayer-1.1-r1

Nyligen den nya mplayer-1.1-r1 ebuild dök upp i portage. I artikeln stereoskopisk mplayer-1.0_rc4_p20110322 förutsatt jag en modifierad patch för stereoskopisk stöd mplayer-1.0_rc4_p20110322. Denna patch fungerar inte med den aktuella versionen längre. Dock har endast en mindre fix krävts. För att använda den nya patchen, bara ladda ner den härifrån: mplayer-stereoskopisk-1.1-r1.patch (594) och kopiera den till:

/etc/portage/patches/media-video/mplayer-1.1-r1/

Efteråt dyka mplayer och spela stereoskopiska filmer med:

mplayer -vo GL2: stereo some_movie_file.avi

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...

Flightgear-2.8.0 med quad buffrad stereo

 Flightgear 2.8.0 with quad buffered stereo

I artikeln Flight med quad buffrad stereo jag har skrivit om hur man får quad buffrad stereo för att arbeta med den berömda flygsimulator Flightgear . Nyligen Flightgear-2.8.0 har släppts. Problemet med quad buffrad stereo kvarstår med Flightgear-2.8.0.

Man räknar med att göra det möjligt för stereoskopisk läge i Flightgear startar den med följande rad:

export OSG_STEREO_MODE = QUAD_BUFFER; export OSG_STEREO = ON; FGF

När du startar Flight detta sätt får man följande bordets utgång och ingen stereoskopisk visning:

Varning: upptäckta OpenGL error "ogiltig operation" efter RenderBin :: draw (,)

Att få Flight att arbeta med quad-buffrad stereo

Anledningen till ovanstående felmeddelande och den resulterande brutna stereoläge är att stereon sammanhanget inte blir initieras korrekt. Detaljerna beskrivs här: Flight med quad buffrad stereo . Tyvärr plåstret jag föreslog i nämnda posten inte fungerar för Flightgear-2.8.0. Men den goda nyheten är, det bara krävs en liten ändring, det WindowBuilder.cxx filen inte längre är i src / Main, men i src / Viewer katalogen. Du kan ladda ner den nya patchen härifrån: Flightgear-2.8.0-stereoscopic.patch (746)

Förhoppningsvis plåstret finner sin väg in i nästa Flight release.

Som vanligt för quad buffrad stereo, måste du använda ett professionellt grafikkort som stöder quad buffrad stereo, som en NVIDIA Quadro FX eller ett Ati FireGL och korrekt display hårdvara, som slutarglasögon, en HMD eller stereoskopisk projektionssystem, för att dra nytta av den. För att använda quad buffrade stereoläge startFlight med miljövariabler som nämns ovan. Efteråt har du förmodligen aktivera quad buffrat stereoläge genom att välja Stereoscopic Visningsalternativ Post på menyn Visa.

Den Gentoo sätt

För gentoo användare har jag skapat ett överlägg. Liksom den tidigare innehåller patchar och modifierade ebuildskript för Flightgear med arbets quad buffertstöd. Du kan få overlay härifrån: Flightgear-2.8.0 overlay (654) Ladda ner overlay och packa den i / usr / local / portage. Se till att inkludera följande rad i din /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Då dyker Flightgear och njuta av det i tre dimensioner.

Ha kul

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...

glsldevil binärer

För ungefär ett år sedan skrev jag om OpenGL / GLSL debugger glsldevil i artikeln gentoo ebuild för glsldevil-1.1.5 och som en gentoo ebuild för det. Tyvärr glsldevil verkar inte vara tillgänglig längre från webbsidan vid universitetet i Stuttgart ( http://cumbia.informatik.uni-stuttgart.de/glsldevil/ ), vilket har gjort det ebuild värdelös.

Edit 29/5/2012: Den ursprungliga nedladdningsplats vid universitetet i Stuttgart är tillgänglig igen.

Eftersom licensen för glsldevil tillåter omfördelning, beslutade jag att lägga upp min lokala kopia, för att göra glsldevil tillgängliga för allmänheten igen. Tyvärr inkluderar endast Linux binärer (32bit och 64bit) och varken Windows binärer eller källkoden.

Du kan ladda ner Linux binärer härifrån: glsldevil-1.1.5.tar.gz (756)

För användning med ebuild, bara kopiera filen till / usr / portage / distfiles /.

hälsningar
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 röster, genomsnitt: 5.00 av 5)
Loading ... Laddar ...

nvidia-drivers-295,17 lösa svart skärm problem

Använda nvidia linux drivrutiner från version 270.X till 275.X med vissa grafikkort, i exempelvis Quadro FX 350M som är inbyggd i Dell Precision M65 bärbara dator, resulterade i en svart skärm eller fönster för OpenGL-program. Även glxgears gjorde bara ut ett svart fönster. Problemet har diskuterats på forums.opensuse.org . En nedgradering till en lägre version av drivrutinen, i exempel versions 260.X förarna är inte tillämplig längre, eftersom dessa förare dot inte bygga mot en ny linux-3-kärnan. En uppgradering till nyare förare var inte möjligt, eftersom drivrutinsversioner från 285.X till 295,10 fungerade inte alls för detta grafikkort. Nyligen version 295,17 av Nvidias beta föraren har blivit tillgängliga, som löser det här problemet. Hämta länkar finns på nvnews.net .

För gentoo användare har jag ändrat de nvidia-drivrutinerna ebuild för 295,17 föraren. Du kan ladda ner min modifierade overlay, nvidia-drivers-295.17.tar.gz (356) och dra den i / usr / local / portage. Se till att inkludera följande rad i din /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Efteråt kan du dyka nvdidia-drivers-295,17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...

Flightgear-2.4.0 med quad buffrad stereo

 Flightgear 2.4.0 with quad buffered stereo

I efter Flight med quad-buffrad stereo jag har skrivit om hur man får quad buffrad stereo för att arbeta med den berömda flygsimulator Flightgear . Nyligen Flightgear-2.4.0 har släppts. Problemet med quad buffrad stereo kvarstår med Flightgear-2.4.0.

Man räknar med att göra det möjligt för stereoskopisk läge i Flightgear startar den med följande rad:

export OSG_STEREO_MODE = QUAD_BUFFER; export OSG_STEREO = ON; FGF

När du startar Flight detta sätt får man följande bordets utgång och ingen stereoskopisk visning:

Varning: upptäckta OpenGL error "ogiltig operation" efter RenderBin :: draw (,)

Att få Flight att arbeta med quad-buffrad stereo

Anledningen till ovanstående felmeddelande och den resulterande brutna stereoläge är att stereon sammanhanget inte blir initieras korrekt. Detaljerna beskrivs här: Flight med quad buffrad stereo . Men den goda nyheten är, att lappen jag föreslog i nämnda post, arbetar fortfarande med Flightgear-2.4.0. Du kan ladda ner patchen härifrån: Flightgear-2.0.0-stereoscopic.patch (792)

Som vanligt för quad buffrad stereo, måste du använda ett professionellt grafikkort som stöder quad buffrad stereo, som en NVIDIA Quadro FX eller ett Ati FireGL och korrekt display hårdvara, som slutarglasögon, en HMD eller stereoskopisk projektionssystem, för att dra nytta av den. För att använda quad buffrade stereoläge startFlight med miljövariabler som nämns ovan. Efteråt har du förmodligen aktivera quad buffrat stereoläge genom att välja Stereoscopic Visningsalternativ Post på menyn Visa.

Med den tidigare versionen, när du använder quad buffrade stereoläge i Flightgear, inträffade några grafiska fel. Vissa cockpit kontroller och andra scendetaljer innehöll gula linjer, som en trådmodell, som inte var där vid start Flight i "normal" visningsläget. Dessa problem verkar vara borta med Flightgear-2.4.0. Åtminstone jag inte märke till dem längre.

Den Gentoo sätt

För gentoo användare har jag skapat ett överlägg. Liksom den tidigare innehåller patchar och modifierade ebuildskript för Flightgear med arbets quad buffertstöd. Du kan få overlay härifrån: Flightgear-2.4.0 overlay (368) Ladda ner overlay och packa den i / usr / local / portage. Se till att inkludera följande rad i din /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Då dyker Flightgear och njuta av det i tre dimensioner.

Ha kul

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...

stereoskopisk mplayer-1.0_rc4_p20110322

Igår den nya mplayer-1.0_rc4_p20110322 ebuild dök upp i portage. I efter stereoskopisk mplayer arbeta igen del 2 förutsatt jag en modifierad patch för stereoskopisk stöd mplayer-1.0_rc4_p20101114. Denna patch fungerar fortfarande med den aktuella versionen. För att använda det, bara ladda ner patchen från det och kopiera den till:

/etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1/

efteråt dyker mplayer och spela stereoskopiska filmer med

mplayer -vo GL2: stereo some_movie_file.avi

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...

bino-1.0 ebuild för gentoo

Nyligen skrev jag om bino , en stereoskopisk videospelare som är användbar med Linux och stöder även quad buffrad stereo. Under tiden den första stabila versionen 1.0 har släppts. Dess viktigaste funktioner är:

  • Stöd för 2D och stereoskopisk 3D-video i en mängd olika inmatningsformat och stereo layouter.
  • Stöd för många 3D-output metoder, bland annat anaglyf glasögon, glasögon, autostereoskopiska skärmar, 3D-TV-apparater, och distribuerade flervisnings installationer såsom powerwalls eller Virtual Reality installationer.

Den Gentoo sätt

För Gentooanvändare här är min overlay inklusive ebuild: bino-1.0_overlay.tar.gz (589) Ladda ner overlay och packa den i / usr / local / portage. Se till att inkludera följande rad i din /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Då dyker bino och njuta tittar dina 3D-filmer.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen uppskattning)
Loading ... Laddar ...
2011/05/04

mygnu Info

blogg rulle

site info

Trans lator

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag