vizionarea imaginilor 3D stereo MPO cu ushare

Acum câteva luni am primit noul meu LG 55LA6608 3D TV. Desigur am vrut sa ma uit la fotografii 3D realizate cu aparatul foto Fujifilm Finepix Real 3D cu ea. Imaginile luate de camera foto sunt stocate în formatul de fișier MPO. Aceste imagini sunt compuse din două imagini JPEG si unele metadate în interiorul antetul Exif interiorul containerului MPO. Potrivit caietului de sarcini televiziunea este capabil de a juca acest format de fișier, care funcționează bine atunci când se utilizează într-un exemplu USB-stick. Cu toate acestea, este de dorit pentru a viziona imaginile folosind o conexiune la rețea, de exemplu atunci când fișierele sunt stocate pe un server Linux.

Pentru a afișa înregistrări video sau imagini de pe un server de acest lucru și alte dispozitive de televiziune folosesc protocolul DLNA, care este implementat de către diverse servicii, cum ar fi Linux minidlna sau ushare. Nici unul dintre cei testați a fost capabil să prezinte dosarele MPO la televizor. Soluția a ushare permite să facă acest lucru este destul de simplu. Tipul mime MPO trebuie să fie adăugate la ushares sprijinite formate de fișiere. Acest lucru poate fi realizat prin adăugarea liniei

{"MPO", UPNP_PHOTO, "http-get: *: image / MPO:"},

la matrice MIME_TYPE_LIST în mime.c. Acest lucru a fost verificat pentru a lucra cu ushare-1.1a. Pentru confortul se poate descărca de patch-uri pentru acest de aici:

ushare-mpo.patch (140)

Se poate descărca sursele ushare de la SourceForge . După descărcarea de patch-uri surselor ushare cu MPO-patch-uri și de a construi o. Construieste și instrucțiunile de utilizare pot fi găsite în fișierul readme inclus în descărcarea ushare de la SourceForge. Nu uita să rulați ./configure -enable-DLNA înainte de a rula face pentru a fi utilizate cu dispozitive recente, cum ar fi menționat LG TV.

Ca de obicei, pentru utilizatorii Gentoo este o modalitate mult mai ușoară: Creați directorul

/ Etc / portage / patch-uri / media-video / ushare /

și plasați fișierul patch-uri de la ea. Asigurați-vă că DLNA USE-pavilion este setat în /etc/make.conf sau /etc/portage/package.use. Ulterior apar ushare din nou și bucura de vizionarea imaginilor 3D MPO stocate pe caseta de Linux folosind TV.

Salutari

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 voturi, medie: 5.00 din 5)
Loading... Se încarcă ...

stereoscopic mplayer-1.1-r1

Recent, noul ebuild mplayer-1,1-r1 apărut în Portage. În articol stereoscopic mplayer-1.0_rc4_p20110322 I, cu condiția un plasture modificate pentru a sprijin stereoscopic în mplayer-1.0_rc4_p20110322. Acest patch nu mai funcționează cu versiunea curentă. Cu toate acestea, a fost nevoie de doar un fix minor. Pentru a utiliza noul patch-uri, doar descarca de aici: mplayer-stereoscopic-1,1-r1.patch (784) și copiați-l:

/etc/portage/patches/media-video/mplayer-1.1-r1/

Emerge Apoi mplayer și reda filme stereoscopice cu:

mplayer -vo GL2: some_movie_file.avi stereo

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Deocamdată nu există evaluări)
Loading... Se încarcă ...

FlightGear-2.8.0 cu quad tamponat stereo

În articolul FlightGear cu quad tamponat stereo , am scris despre cum să obțineți quad stereo tamponată de a lucra cu celebrul simulator de zbor FlightGear . Recent FlightGear-2.8.0 a fost lansat. Problema cu quad stereo tamponat încă persistă cu FlightGear-2.8.0.

Un asteapta pentru a activa modul stereoscopic în FlightGear începând cu următoarea linie:

OSG_STEREO_MODE export = QUAD_BUFFER; export OSG_STEREO = ON; FGF

Când începe FlightGear acest fel, se obține următoarea consola și fără vedere stereoscopic:

Atenție: detectată OpenGL eroare "operațiune invalid", după RenderBin :: remiză (,)

Noțiuni de bază FlightGear de a lucra cu tamponat-quad stereo

Motivul pentru mesajul de eroare de mai sus și modul stereo rupt rezultată este, că, în contextul stereo nu se initializa corect. Detaliile sunt descrise aici: FlightGear cu quad tamponat stereo . Din păcate, plasturele am propus în postul menționat nu funcționează pentru-FlightGear 2.8.0. Cu toate acestea, vestea bună e că cere doar o ușoară modificare, dosarul WindowBuilder.cxx nu mai este în src / Main, dar în directorul src / Viewer. Puteți descărca noul patch de aici: FlightGear-2.8.0-stereoscopic.patch (936)

Să sperăm că plasturele se regăsește în următoarea versiune FlightGear.

Ca de obicei pentru quad tamponat stereo, va trebui să utilizați un bord profesional grafică ce suportă quad tamponată stereo, ca un FX NVIDIA Quadro sau un ATI FireGL și hardware-ul de afișare corespunzător, cum ar fi ochelari shutter, un HMD sau un sistem de proiecție stereoscopică, de a beneficia de ea. Pentru a utiliza quad tamponat modul stereo start FlightGear cu variabilele de mediu menționate mai sus. După aceea, probabil, va trebui să activați quad tamponat modul stereo prin selectarea Stereoscopic Opțiuni Vizualizare Postul din meniul View.

Modul Gentoo

Pentru utilizatorii Gentoo am creat o suprapunere. Ca cel anterior conține patch-uri și fișiere ebuild modificate pentru FlightGear cu suport de lucru tampon quad. Puteți obține masca de aici: FlightGear-2.8.0 acoperire (913) Descărcați suprapunere și extrage-l în / usr / local / portage. Asigurați-vă că pentru a include următoarea linie în /etc/make.conf dumneavoastră:

Variabila PORTDIR_OVERLAY = "/ usr / local / portage"

Apoi apar FlightGear și se bucure de ea în trei dimensiuni.

Distrează-te

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 voturi, medie: 5.00 din 5)
Loading... Se încarcă ...

binare glsldevil

Aproximativ un an am scris despre OpenGL / GLSL depanator glsldevil în articol gentoo ebuild pentru glsldevil-1.1.5 și a oferit un ebuild gentoo pentru ea. Din păcate, glsldevil nu pare a fi disponibil mai de pe pagina web a Universității din Stuttgart ( http://cumbia.informatik.uni-stuttgart.de/glsldevil/ ), care a prestat ebuild inutil.

Edit 29/5/2012: inițial Site-ul de descărcare de la Universitatea din Stuttgart se află din nou disponibil.

Având în vedere că licența de glsldevil permite redistribuire, am decis să încărcați copia mea locală, pentru a face glsldevil dispoziția publicului din nou. Din păcate, aceasta include doar binare Linux (pe 32 de biți și 64 de biți) și nici binare Windows sau codul sursă.

Puteți descărca fișierele binare Linux de aici: glsldevil-1.1.5.tar.gz (1089)

Pentru utilizare cu ebuild, copiați doar fișierul / usr / portage / distfiles /.

Salutari
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (2 voturi, medie: 5.00 din 5)
Loading... Se încarcă ...

nvidia-drivers-295.17 rezolva problema ecran negru

Utilizarea drivere linux nvidia de la versiunea 270.X la 275.X cu unele placi grafice, în exemplul Quadro FX 350M, care este construit în notebook Dell Precision M65, a dus la un ecran negru sau fereastră pentru aplicații OpenGL. Chiar glxgears făcut doar de ieșire-o fereastră neagră. Problema a fost discutată pe forums.opensuse.org . Un downgrade la o versiune mai mică conducător auto, în exemplul versiunea 260.X șoferii nu mai este aplicabil, deoarece aceste drivere construim punct față de un recent kernel linux-3. Un upgrade la drivere mai noi, de asemenea, nu a fost posibil, deoarece versiunile driver de la 285.X la 295.10 nu au de lucru la toate pentru acest bord grafică. Recent versiune 295.17 de conducător auto nvidias beta au devenit disponibile, care rezolvă această problemă. Descarca link-uri sunt disponibile pe nvnews.net .

Pentru utilizatorii Gentoo am modificat nvidia-driverele ebuild pentru driver-ul 295.17. Puteți descărca de acoperire, modificate meu nvidia-drivers-295.17.tar.gz (465) și se extrage-l în / usr / local / portage. Asigurați-vă că pentru a include următoarea linie în /etc/make.conf dumneavoastră:

Variabila PORTDIR_OVERLAY = "/ usr / local / portage"

Ulterior s-ar putea emerge nvdidia-drivers-295.17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Deocamdată nu există evaluări)
Loading... Se încarcă ...

FlightGear-2.4.0 cu quad tamponat stereo

În postul FlightGear cu quad tamponat stereo , am scris despre cum să obțineți quad stereo tamponată de a lucra cu celebrul simulator de zbor FlightGear . Recent FlightGear-2.4.0 a fost lansat. Problema cu quad stereo tamponat încă persistă cu FlightGear-2.4.0.

Un asteapta pentru a activa modul stereoscopic în FlightGear începând cu următoarea linie:

OSG_STEREO_MODE export = QUAD_BUFFER; export OSG_STEREO = ON; FGF

Când începe FlightGear acest fel, se obține următoarea consola și fără vedere stereoscopic:

Atenție: detectată OpenGL eroare "operațiune invalid", după RenderBin :: remiză (,)

Noțiuni de bază FlightGear de a lucra cu tamponat-quad stereo

Motivul pentru mesajul de eroare de mai sus și modul stereo rupt rezultată este, că, în contextul stereo nu se initializa corect. Detaliile sunt descrise aici: FlightGear cu quad tamponat stereo . Cu toate acestea, vestea bună este că plasturele am propus în postul menționat, încă mai lucrează cu FlightGear-2.4.0. Puteți descărca de patch-uri de aici: FlightGear-2.0.0-stereoscopic.patch (908)

Ca de obicei pentru quad tamponat stereo, va trebui să utilizați un bord profesional grafică ce suportă quad tamponată stereo, ca un FX NVIDIA Quadro sau un ATI FireGL și hardware-ul de afișare corespunzător, cum ar fi ochelari shutter, un HMD sau un sistem de proiecție stereoscopică, de a beneficia de ea. Pentru a utiliza quad tamponat modul stereo start FlightGear cu variabilele de mediu menționate mai sus. După aceea, probabil, va trebui să activați quad tamponat modul stereo prin selectarea Stereoscopic Opțiuni Vizualizare Postul din meniul View.

Cu versiunea anterioară, atunci când se utilizează quad tamponat modul stereo în FlightGear, s-au produs unele erori grafice. Unele controale din cabina de pilotaj și alte detalii scena conținute linii galbene, cum ar fi un wireframe, care nu au fost acolo atunci când au început FlightGear în modul de afișare "normal". Aceste probleme par a fi căzut cu FlightGear-2.4.0. Cel puțin eu nu le-am mai observat.

Modul Gentoo

Pentru utilizatorii Gentoo am creat o suprapunere. Ca cel anterior conține patch-uri și fișiere ebuild modificate pentru FlightGear cu suport de lucru tampon quad. Puteți obține masca de aici: FlightGear-2.4.0 acoperire (475) Descărcați suprapunere și extrage-l în / usr / local / portage. Asigurați-vă că pentru a include următoarea linie în /etc/make.conf dumneavoastră:

Variabila PORTDIR_OVERLAY = "/ usr / local / portage"

Apoi apar FlightGear și se bucure de ea în trei dimensiuni.

Distrează-te

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 voturi, medie: 5.00 din 5)
Loading... Se încarcă ...

stereoscopic mplayer-1.0_rc4_p20110322

Ieri noul ebuild mplayer-1.0_rc4_p20110322 apărut în Portage. În post- MPLayer stereoscopic de lucru din nou partea 2 I, cu condiția un plasture modificate pentru a sprijin stereoscopic în mplayer-1.0_rc4_p20101114. Acest patch va funcționa cu versiunea curentă. Pentru a utiliza, descarcati doar patch-uri de acolo și copiați-l:

/etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1/

emerge după aceea mplayer și reda filme stereoscopice cu

mplayer -vo GL2: some_movie_file.avi stereo

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (1 voturi, medie: 5.00 din 5)
Loading... Se încarcă ...

info site-ul

Trans lator

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag