stereoskopisk mplayer-1.1-r1

Nylig den nye mplayer-1.1-r1 ebuild dukket opp i Portage. I artikkelen stereoskopisk mplayer-1.0_rc4_p20110322 ga jeg en modifisert patch for stereoskopisk støtte i mplayer-1.0_rc4_p20110322. Denne oppdateringen fungerer ikke med den nåværende versjonen lenger. Men har bare en mindre fix vært nødvendig. For å bruke den nye patchen, bare laste det ned her: mplayer-stereoskopisk-1.1-r1.patch (470) og kopiere den til:

/ Etc/portage/patches/media-video/mplayer-1.1-r1 /

Etterpå dukker mplayer og spille stereoskopiske filmer med:

mplayer-vo gl2: stereo some_movie_file.avi

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...

Flightgear-2.8.0 med quad bufret stereo

 Flightgear 2.8.0 with quad buffered stereo

I artikkelen Flight med quad bufret stereo har jeg skrevet om hvordan du kan få quad bufret stereo til å jobbe med den berømte flysimulator Flightgear . Nylig Flightgear-2.8.0 har blitt utgitt. Problemet med quad bufret stereo vedvarer med Flightgear-2.8.0.

Man forventer å aktivere stereoskopisk modus i Flight starter det med følgende linje:

eksport OSG_STEREO_MODE = QUAD_BUFFER; eksport OSG_STEREO = PÅ; FGFs

Når du starter flight denne måten, får man følgende konsollen utgang og ingen stereoskopisk syn:

Advarsel: oppdaget OpenGL error 'ugyldig operasjon' etter RenderBin :: uavgjort (,)

Komme Flight å jobbe med quad-bufret stereo

Bakgrunnen for ovennevnte feilmelding, og den resulterende knust stereomodus er, at stereo sammenheng ikke blir initialisert riktig. Detaljene er beskrevet her: Flight med quad bufret stereo . Dessverre lappen jeg foreslått i nevnte innlegget ikke fungerer for flight-2.8.0. Men den gode nyheten er, det kreves bare en liten endring, den WindowBuilder.cxx filen ikke lenger er i src / Main, men i src / Viewer katalogen. Du kan laste ned den nye oppdateringen fra her: flight-2.8.0-stereoscopic.patch (620)

Forhåpentligvis oppdateringen finner sin vei inn i neste flight utgivelsen.

Som vanlig for quad bufret stereo, må du bruke en profesjonell grafikkort som støtter quad bufret stereo, som en NVIDIA Quadro FX eller et ATI FireGL og korrekt visning hardware, som shutter-briller, en HMD eller et stereoskopisk projeksjon system, for å dra nytte av den. For å bruke quad bufret stereo modus start flight med miljøvariablene som er nevnt ovenfor. Etterpå har du sannsynligvis nødt til å aktivere quad bufret stereo modus ved å velge stereoskopisk visningsvalg element i Vis-menyen.

Den Gentoo måte

For bøyle brukere har jeg laget et overlegg. Som den forrige den inneholder patcher og modifiserte ebuilds for flight med arbeids quad buffer støtte. Du kan få overlegget her: flight-2.8.0 overlegg (539) Last ned overlegg og pakk den i / usr / local / portage. Sørg for å inkludere følgende linje i / etc / make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Deretter dukker flight og nyte det i tre dimensjoner.

Ha det gøy

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...

glsldevil binærfiler

Om ett år siden skrev jeg om OpenGL / GLSL debugger glsldevil i artikkelen gentoo ebuild for glsldevil-1.1.5 og gitt en gentoo ebuild for det. Dessverre glsldevil synes ikke å være tilgjengelig lenger fra nettsidene til Universitetet i Stuttgart ( http://cumbia.informatik.uni-stuttgart.de/glsldevil/ ), som har gjort det ebuild ubrukelig.

Redigere 29/5/2012: Den opprinnelige nedlastingsside ved Universitetet i Stuttgart er tilgjengelig igjen.

Siden lisensen av glsldevil tillater redistribusjon, bestemte jeg meg for å laste opp min lokale kopi, for å gjøre glsldevil tilgjengelig for publikum igjen. Dessverre er dette bare omfatter Linux binærfiler (32bit og 64bit) og verken Windows binærfiler eller kildekoden.

Du kan laste ned Linux-binærfiler fra her: glsldevil-1.1.5.tar.gz (647)

For bruk med ebuild, bare kopiere filen til / usr / portage / distfiles /.

hilsen
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 stemmer, gjennomsnitt: 5.00 ut av 5)
Loading ... Loading ...

nvidia-drivere-295,17 løse svart skjerm problem

Bruke NVIDIA linux drivere fra versjon 270.X å 275.X med noen grafikkort, i eksempel Quadro FX 350M som er innebygd i Dell Precision M65 bærbar PC, resulterte i en svart skjerm eller et vindu for OpenGL-programmer. Selv glxgears gjorde bare utgang et svart vindu. Problemet har vært diskutert på forums.opensuse.org . En nedgradering til en lavere driverversjon, i eksempel den versjonen 260.X drivere er ikke aktuelt lenger, siden disse driverne dot bygge mot en fersk linux-3-kjernen. En oppgradering til nyere drivere var heller ikke mulig, siden driverversjoner fra 285.X til 295,10 fungerte ikke i det hele tatt for dette grafikkortet. Nylig versjon 295,17 av Nvidias beta-driver har blitt tilgjengelig, som løser dette problemet. Last ned koblinger er tilgjengelig på nvnews.net .

For bøyle brukere har jeg endret de nvidia-drivere ebuild for 295,17 sjåføren. Du kan laste ned min endret overlegg, nvidia-drivere-295.17.tar.gz (294) og pakk den i / usr / local / portage. Sørg for å inkludere følgende linje i / etc / make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Etterpå kan du dukke nvdidia-drivere-295,17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...

Flightgear-2.4.0 med quad bufret stereo

 Flightgear 2.4.0 with quad buffered stereo

I innlegget Flight med quad bufret stereo jeg har skrevet om hvordan du får quad bufret stereo til å jobbe med den berømte flysimulator Flightgear . Nylig Flightgear-2.4.0 har blitt utgitt. Problemet med quad bufret stereo vedvarer med Flightgear-2.4.0.

Man forventer å aktivere stereoskopisk modus i Flight starter det med følgende linje:

eksport OSG_STEREO_MODE = QUAD_BUFFER; eksport OSG_STEREO = PÅ; FGFs

Når du starter flight denne måten, får man følgende konsollen utgang og ingen stereoskopisk syn:

Advarsel: oppdaget OpenGL error 'ugyldig operasjon' etter RenderBin :: uavgjort (,)

Komme Flight å jobbe med quad-bufret stereo

Bakgrunnen for ovennevnte feilmelding, og den resulterende knust stereomodus er, at stereo sammenheng ikke blir initialisert riktig. Detaljene er beskrevet her: Flight med quad bufret stereo . Men den gode nyheten er, at lappen jeg foreslått i nevnte innlegg, jobber fortsatt med Flightgear-2.4.0. Du kan laste ned oppdateringen fra her: flight-2.0.0-stereoscopic.patch (722)

Som vanlig for quad bufret stereo, må du bruke en profesjonell grafikkort som støtter quad bufret stereo, som en NVIDIA Quadro FX eller et ATI FireGL og korrekt visning hardware, som shutter-briller, en HMD eller et stereoskopisk projeksjon system, for å dra nytte av den. For å bruke quad bufret stereo modus start flight med miljøvariablene som er nevnt ovenfor. Etterpå har du sannsynligvis nødt til å aktivere quad bufret stereo modus ved å velge stereoskopisk visningsvalg element i Vis-menyen.

Med den forrige versjonen, når du bruker quad bufret stereo modus i flight, det oppstod noen grafiske feil. Noen cockpit kontroller og andre scene detaljer inneholdt gule linjer, som en wireframe, som ikke var der når du starter Flight i "normal" modus. Disse problemene ser ut til å være borte med Flightgear-2.4.0. Minst gjorde jeg ikke merke til dem lenger.

Den Gentoo måte

For bøyle brukere har jeg laget et overlegg. Som den forrige den inneholder patcher og modifiserte ebuilds for flight med arbeids quad buffer støtte. Du kan få overlegget her: flight-2.4.0 overlegg (315) Last ned overlegg og pakk den i / usr / local / portage. Sørg for å inkludere følgende linje i / etc / make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Deretter dukker flight og nyte det i tre dimensjoner.

Ha det gøy

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...

stereoskopisk mplayer-1.0_rc4_p20110322

I går den nye mplayer-1.0_rc4_p20110322 ebuild dukket opp i Portage. I innlegget stereoskopisk mplayer jobbe igjen del 2 følger jeg en modifisert patch for stereoskopisk støtte i mplayer-1.0_rc4_p20101114. Denne oppdateringen fungerer fortsatt med den nåværende versjonen. For å bruke det, bare laste ned oppdateringen fra det og kopiere den til:

/ Etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1 /

etterpå dukker mplayer og spille stereoskopiske filmer med

mplayer-vo gl2: stereo some_movie_file.avi

mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...

Bino-1.0 ebuild for gentoo

Nylig skrev jeg om Bino , en stereoskopisk videospiller som er brukbart med linux og også støtter quad bufret stereo. I mellomtiden den første stabile versjon 1.0 har blitt utgitt. Dens viktigste funksjoner er:

  • Støtte for 2D og stereoskopisk 3D-video i en rekke innspill formater og stereooppsett.
  • Støtte for mange 3D utgang metoder, inkludert anaglyph briller, shutter-briller, autostereoscopic skjermer, 3D-TV-apparater, og distribuerte flerskjerminstallasjoner som powerwalls eller Virtual Reality installasjoner.

Den Gentoo måte

For bøyle brukere her er min overlegg inkludert ebuild: bino-1.0_overlay.tar.gz (527) Last ned overlegg og pakk den i / usr / local / portage. Sørg for å inkludere følgende linje i / etc / make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Deretter dukker bino, og få se dine 3D-filmer.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Ingen stemmer ennå)
Loading ... Loading ...
2011-05-04

mygnu info

blogg roll

site info

Trans lator

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag