estereoscópica mplayer-1.1-r1

Recientemente el nuevo ebuild mplayer-1.1-r1 apareció en portage. En el artículo estereoscópica mplayer-1.0_rc4_p20110322 proporcioné un parche modificado para soporte estereoscópico en mplayer-1.0_rc4_p20110322. Este parche no funciona con la versión actual más. Sin embargo, sólo una solución menor ha sido necesario. Para utilizar el nuevo parche, sólo tiene que descargar desde aquí: mplayer-estereoscópica-1,1-r1.patch (653) , con copia a:

/etc/portage/patches/media-video/mplayer-1.1-r1/

Emerger Después mplayer y reproducir películas estereoscópicas con:

mplayer -vo gl2: some_movie_file.avi estéreo

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...

Flightgear-2.8.0 con cuatro buffers estéreo

 Flightgear 2.8.0 with quad buffered stereo

En el artículo Flightgear con cuatro buffers de música que he escrito acerca de cómo obtener quad estéreo tamponada para trabajar con el famoso simulador de vuelo FlightGear . Recientemente FlightGear-2.8.0 ha sido liberado. El problema con quad estéreo tamponada persiste con FlightGear-2.8.0.

Uno espera para habilitar el modo estereoscópico en FlightGear comenzando con la siguiente línea:

OSG_STEREO_MODE exportación = QUAD_BUFFER; exportación OSG_STEREO = ON; fgfs

Al iniciar flightgear esta manera, se obtiene la siguiente salida de la consola y sin visión estereoscópica:

Advertencia: detectado error OpenGL "operación no válida" después RenderBin :: empate (,)

Conseguir FlightGear para trabajar con equipo de música con búfer cuadrafónico

La razón para el mensaje de error anterior y el modo estéreo roto resultante es, que el contexto estéreo no consigue inicializado correctamente. Los detalles se describen a continuación: Flightgear con cuatro buffers estéreo . Desafortunadamente el parche propuse en el post mencionado no funciona para flightgear-2.8.0. Sin embargo, la buena noticia es que sólo se requiere una ligera modificación, el archivo WindowBuilder.cxx ya no está en src / Main, pero en el directorio / src Visor. Puede descargar el nuevo parche de aquí: flightgear-2.8.0-stereoscopic.patch (794)

Esperemos que el parche se abre paso en la próxima versión flightgear.

Como es habitual en quad tamponada estéreo, usted tiene que utilizar una tarjeta gráfica profesional que soporta quad tamponada estéreo, como una NVIDIA Quadro FX o ATI FireGL y hardware de visualización adecuado, como gafas de obturación, un HMD o un sistema de proyección estereoscópica, para beneficiarse de la ella. Para utilizar el quad tamponada modo estéreo inicio flightgear con las variables de entorno antes mencionadas. Después es probable que tenga que activar el modo estéreo de cuatro buffers seleccionando la estereoscópica Ver las opciones de artículos en el menú de la Vista.

La forma en Gentoo

Para los usuarios de Gentoo He creado una superposición. Al igual que la anterior que contiene parches y ebuilds modificados para flightgear con el apoyo de búfer cuádruple de trabajo. Usted puede obtener la superposición de aquí: flightgear-2.8.0 superposición (709) Descargar la plantilla y extraerlo en / usr / local / portage. Asegúrese de incluir la siguiente línea en su /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Entonces surgirá flightgear y disfrutar de ella en tres dimensiones.

Divertirse

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...

binarios glsldevil

Hace aproximadamente un año escribí sobre el depurador glsldevil OpenGL / GLSL en el artículo ebuild Gentoo para glsldevil-1.1.5 y proporcionó un ebuild Gentoo por ello. Desafortunadamente glsldevil parece no estar disponible ya en la página web de la Universidad de Stuttgart ( http://cumbia.informatik.uni-stuttgart.de/glsldevil/ ), que ha hecho que la inútil ebuild.

Editar 29/5/2012: El sitio de descarga original de la Universidad de Stuttgart está disponible de nuevo.

Dado que la licencia de glsldevil permite la redistribución, decidí subir mi copia local, para hacer glsldevil disponible para el público de nuevo. Desafortunadamente esto sólo incluye los binarios de Linux (32 bits y 64 bits) y ni los binarios de Windows o el código fuente.

Puedes descargar los binarios de Linux desde aquí: glsldevil-1.1.5.tar.gz (834)

Para el uso con el ebuild, sólo tienes que copiar el archivo a / usr / portage / distfiles /.

saludos
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 votos, promedio: 5.00 de 5)
Loading ... Cargando ...

nvidia-drivers-295.17 resolver problema pantalla en negro

Uso de controladores Linux de NVIDIA desde la versión 270.X a 275.X con algunas tarjetas gráficas, en el ejemplo de la Quadro FX 350M que está integrado en el portátil Dell Precision M65, resultó en una pantalla en negro o ventana para aplicaciones OpenGL. Incluso glxgears hicieron sólo sale una ventana de negro. El problema ha sido discutido en forums.opensuse.org . Una rebaja a una versión menor del conductor, en el ejemplo de los controladores de versión 260.X no es aplicable más, ya que estos conductores de puntos se acumulan en contra de un reciente kernel linux-3. Una actualización a los controladores más recientes también no fue posible, ya que las versiones de controladores de 285.X a 295,10 no funcionaron en absoluto para esta tarjeta gráfica. Recientemente versión 295.17 del controlador de Nvidia beta se ha convertido en disponible, que resuelve este problema. Los enlaces de descarga están disponibles en nvnews.net .

Para los usuarios de Gentoo he modificado los nvidia-drivers ebuild para el conductor 295.17. Puede descargar mi superposición, modificados nvidia-drivers-295.17.tar.gz (375) y extraerlo en / usr / local / portage. Asegúrese de incluir la siguiente línea en su /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Después usted puede surgir nvdidia-drivers-295.17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...

Flightgear-2.4.0 con cuatro buffers estéreo

 Flightgear 2.4.0 with quad buffered stereo

En el post Flightgear con cuatro buffers de música que he escrito acerca de cómo obtener quad estéreo tamponada para trabajar con el famoso simulador de vuelo FlightGear . Recientemente FlightGear-2.4.0 ha sido liberado. El problema con quad estéreo tamponada persiste con FlightGear-2.4.0.

Uno espera para habilitar el modo estereoscópico en FlightGear comenzando con la siguiente línea:

OSG_STEREO_MODE exportación = QUAD_BUFFER; exportación OSG_STEREO = ON; fgfs

Al iniciar flightgear esta manera, se obtiene la siguiente salida de la consola y sin visión estereoscópica:

Advertencia: detectado error OpenGL "operación no válida" después RenderBin :: empate (,)

Conseguir FlightGear para trabajar con equipo de música con búfer cuadrafónico

La razón para el mensaje de error anterior y el modo estéreo roto resultante es, que el contexto estéreo no consigue inicializado correctamente. Los detalles se describen a continuación: Flightgear con cuatro buffers estéreo . Sin embargo, la buena noticia es, que el parche que propuse en el post mencionado, todavía trabaja con FlightGear-2.4.0. Puede descargar el parche desde aquí: flightgear-2.0.0-stereoscopic.patch (818)

Como es habitual en quad tamponada estéreo, usted tiene que utilizar una tarjeta gráfica profesional que soporta quad tamponada estéreo, como una NVIDIA Quadro FX o ATI FireGL y hardware de visualización adecuado, como gafas de obturación, un HMD o un sistema de proyección estereoscópica, para beneficiarse de la ella. Para utilizar el quad tamponada modo estéreo inicio flightgear con las variables de entorno antes mencionadas. Después es probable que tenga que activar el modo estéreo de cuatro buffers seleccionando la estereoscópica Ver las opciones de artículos en el menú de la Vista.

Con la versión anterior, cuando se utiliza el modo estéreo de cuatro buffers en flightgear, se produjo algunos errores gráficos. Algunos controles de la cabina y otros detalles de la escena contenían líneas amarillas, como un alambre, que no estaban allí cuando se inicia FlightGear en modo de visualización "normal". Estos problemas parecen haber desaparecido con Flightgear-2.4.0. Por lo menos yo no me di cuenta de ellos nunca más.

La forma en Gentoo

Para los usuarios de Gentoo He creado una superposición. Al igual que la anterior que contiene parches y ebuilds modificados para flightgear con el apoyo de búfer cuádruple de trabajo. Usted puede obtener la superposición de aquí: flightgear-2.4.0 superposición (391) Descargar la plantilla y extraerlo en / usr / local / portage. Asegúrese de incluir la siguiente línea en su /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Entonces surgirá flightgear y disfrutar de ella en tres dimensiones.

Divertirse

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...

estereoscópica mplayer-1.0_rc4_p20110322

Ayer el nuevo ebuild mplayer-1.0_rc4_p20110322 apareció en portage. En el post mplayer estereoscópica a trabajar de nuevo parte 2 proporcioné un parche modificado para soporte estereoscópico en mplayer-1.0_rc4_p20101114. Este parche funcionará con la versión actual. Para utilizarlo, sólo tiene que descargar el parche desde allí, con copia a:

/etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1/

emerger después mplayer y reproducir películas estereoscópicas con

mplayer -vo gl2: some_movie_file.avi estéreo

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...

bino-1.0 ebuild para Gentoo

Recientemente escribí sobre bino , un reproductor de vídeo estereoscópico que se puede utilizar con linux y también soporta quad tamponada estéreo. Mientras tanto la primera versión estable 1.0 ha sido liberado. Sus principales características son:

  • Soporte para 2D y vídeo 3D estereoscópico en una amplia variedad de formatos de entrada y diseños estéreo.
  • Soporte para muchos métodos de salida de 3D, incluyendo gafas anaglifo, gafas de obturación, pantallas autoestereoscópicos, televisores 3D, e instalaciones de múltiples pantallas distribuidas como powerwalls o instalaciones de Realidad Virtual.

La forma en Gentoo

Para los usuarios de Gentoo aquí está mi superposición incluyendo el ebuild: bino-1.0_overlay.tar.gz (608) Descargar la plantilla y extraerlo en / / local / portage usr. Asegúrese de incluir la siguiente línea en su /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Entonces surgirá bino y disfrutar de ver sus películas en 3D.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Sin evaluar)
Loading ... Cargando ...
2011-05-04

info mygnu

el blog rollo

información del sitio

Trans lador

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag