veient imatges mpo estèreo 3D amb ushare

Fa uns mesos vaig tenir el meu nou LG 55LA6608 3D TV. Per descomptat que volia veure les fotos en 3D preses amb la càmera Fujifilm Finepix Real 3D amb ella. Les imatges preses per la càmera s'emmagatzemen utilitzant el format de fitxer MPO. Aquestes imatges es componen de dues imatges jpeg i algunes metadades dins de la capçalera EXIF ​​dins del contenidor MPO. D'acord amb l'especificació de la televisió és capaç de reproduir aquest format d'arxiu, que funciona bé quan s'utilitza en l'exemple d'una memòria USB. No obstant això, és desitjable per veure les imatges mitjançant una connexió de xarxa, per exemple, quan els arxius s'emmagatzemen en un servidor linux.

Per a la visualització de vídeos o imatges des d'un servidor d'aquest i altres dispositius de televisió utilitzen el protocol DLNA, que es realitza mitjançant els diferents serveis de linux com minidlna o ushare. Cap dels provats estimats era capaç de presentar els arxius MPO al televisor. La solució per habilitar ushare de fer això és bastant simple. El tipus mime MPO ha de ser afegit a ushares suportats formats d'arxiu. Això es pot fer mitjançant l'addició de la línia de

{"MPO", UPNP_PHOTO "http-get: *: image / mpo:"},

a la matriu MIME_TYPE_LIST en mime.c. Això ha estat verificat per treballar amb el ushare-1.1a. Per a més comoditat es pot descarregar el pegat per això des d'aquí:

ushare-mpo.patch (251)

Es pot obtenir les fonts uShare des SourceForge. Després de descarregar el pegat les fonts uShare amb el mpo-pegat i construir-lo. Construir i instruccions d'ús es poden trobar al fitxer Llegiu-me inclòs en la descàrrega ushare des SourceForge. No s'oblidi d'executar ./configure --enable-DLNA abans d'executar make per al seu ús amb dispositius recents com l'esmentat LG TV.

Com en general, per als usuaris de Gentoo hi ha una manera més fàcil: Creu el directori

/ Etc / portage / pedaços / mitjana-vídeo / ushare /

i col·locar l'arxiu de pegat en el mateix. Assegureu-vos que el DLNA USO-indicador s'estableix en /etc/make.conf o /etc/portage/package.use. Després sorgirà ushare de nou i gaudir veient imatges 3D MPO emmagatzemats al sistema Linux amb el vostre televisor.

salutacions

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 vots, mitjana: 5.00 de 5)
Loading... Carregant ...

estereoscòpica mplayer-1.1-r1

Recentment el nou ebuild mplayer-1.1-r1 va aparèixer en portage. En l'article estereoscòpica mplayer-1.0_rc4_p20110322 vaig proporcionar un pegat modificat pel suport estereoscòpica en mplayer-1.0_rc4_p20110322. Aquest pegat no funciona amb la versió actual més. No obstant això, només una solució de menor importància s'ha requerit. Per utilitzar el nou pegat, simplement descarregar des d'aquí: mplayer-estereoscòpica-1,1-r1.patch (855), amb còpia a:

/etc/portage/patches/media-video/mplayer-1.1-r1/

Emergir Després mplayer i reproduir pel·lícules estereoscòpiques amb:

mplayer -vo GL2: some_movie_file.avi estèreo

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (Sense avaluar)
Loading... Carregant ...

FlightGear-2.8.0 amb quad tamponada estèreo

En l'article FlightGear amb quad tampó de música que he escrit sobre com obtenir quad estèreo tamponada per treballar amb el famós simulador de vol FlightGear. Recentment FlightGear-2.8.0 ha estat alliberat. El problema amb quad estèreo tamponada persisteix amb FlightGear-2.8.0.

Un espera per habilitar la manera estereoscòpic en FlightGear començant amb la següent línia:

OSG_STEREO_MODE exportació = QUAD_BUFFER; exportació OSG_STEREO = ON; fgfs

En iniciar FlightGear aquesta manera, s'obté la següent sortida de la consola i sense visió estereoscòpica:

Són els detectat error OpenGL "operació no vàlida" després RenderBin :: empat (,)

Aconseguir FlightGear per treballar amb equip de música amb memòria intermèdia cuadrafónico

La raó per al missatge d'error anterior i la manera estèreo trencat resultant és, que el context estèreo no aconsegueix inicialitzat correctament. Els detalls es descriuen a continuació: FlightGear amb quad tamponada estèreo. Desafortunadament el pegat que vaig proposar en el post esmentat no funciona per a FlightGear-2.8.0. No obstant això, la bona notícia és que només es requereix una lleugera modificació, l'arxiu WindowBuilder.cxx ja no està en src / Main, però en el directori / Visor src. Podeu descarregar el nou pegat des d'aquí: FlightGear-2.8.0-stereoscopic.patch (1029)

Esperem que el pegat s'obre pas en la propera versió de FlightGear.

Com és habitual en quad tamponada estèreo, vostè ha d'utilitzar una targeta gràfica professional que suporta quad tamponada estèreo, com una NVIDIA Quadro FX o ATI FireGL i maquinari correcta visualització, com ulleres d'obturació, 1 HMD o un sistema de projecció estereoscòpica, per beneficiar- ella. Per utilitzar el quad tamponada manera estèreo inici FlightGear amb les variables d'entorn abans esmentades. Després és probable que hagi d'activar el mode estèreo de quatre buffers seleccionant la estereoscòpica Veure les opcions d'articles al menú de la vista.

La forma en Gentoo

Per als usuaris de Gentoo He creat una superposició. Igual que l'anterior que conté pegats i ebuilds modificats per FlightGear amb el suport de memòria intermèdia quàdruple de treball. Vostè pot obtenir la superposició d'aquí: FlightGear-2.8.0 superposició (1027) Descarregar la plantilla i extreure a / / local / portage usr. Assegureu-vos d'incloure la següent línia en el seu /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Llavors sorgirà FlightGear i gaudir-ne en tres dimensions.

Diverteix-te

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 vots, mitjana: 5.00 de 5)
Loading... Carregant ...

binaris glsldevil

Fa aproximadament un any que vaig escriure sobre el depurador glsldevil OpenGL / GLSL en l'article ebuild Gentoo per glsldevil-1.1.5 i va proporcionar un ebuild Gentoo per això. Desafortunadament glsldevil no sembla ser el hi haurà mes, des de la pàgina web de la Universitat de Stuttgart (http://cumbia.informatik.uni-stuttgart.de/glsldevil/), que ha fet que la inútil ebuild.

Edita 29/5/2012: El lloc de descàrrega original de la Universitat de Stuttgart està disponible de nou.

Des de la llicència de glsldevil permet la redistribució, vaig decidir pujar la meva còpia local, per fer glsldevil disponible per al públic de nou. Malauradament, només inclou els binaris de Linux (32 bits i 64 bits) i ni els binaris de Windows o el codi font.

Podeu descarregar els binaris de Linux des d'aquí: glsldevil-1.1.5.tar.gz (1240)

Per a l'ús amb el ebuild, només has de copiar el fitxer a / usr / portage / distfiles /.

salutacions
Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (2 vots, mitjana: 5.00 de 5)
Loading... Carregant ...

nvidia-drivers-295.17 resoldre el problema de la pantalla en negre

Ús de controladors Linux de NVIDIA des de la versió 270.X a 275.X amb algunes targetes gràfiques, en l'exemple de la Quadro FX 350M que està integrat en el portàtil Dell Precision M65, es va traduir en una pantalla en negre o finestra per a aplicacions OpenGL. Fins i tot glxgears van fer només surt una finestra de negre. El problema ha estat discutit en forums.opensuse.org. Una rebaixa a una versió menor del conductor, en l'exemple dels controladors de versió 260.X no és aplicable més, ja que aquests conductors de punts s'acumulen en contra d'un recent nucli linux-3. Una actualització als controladors més recents també no era possible, ja que les versions de controladors de 285.X a 295,10 no funcionen en absolut per aquesta targeta gràfica. Recentment versió 295.17 del controlador de Nvidia beta s'ha convertit en disponible, que resol aquest problema. Els enllaços de descàrrega estan disponibles a nvnews.net.

Per als usuaris de Gentoo he modificat els conductors nvidia ebuild per al conductor 295.17. Pots descarregar el meu superposició, modificats nvidia-drivers-295.17.tar.gz (552) i extreure en / usr / local / portage. Assegureu-vos d'incloure la següent línia en el seu /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Posteriorment és possible que sorgeixin nvdidia-drivers-295.17.

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (Sense avaluar)
Loading... Carregant ...

FlightGear-2.4.0 amb quad tamponada estèreo

En el post FlightGear amb quad tampó de música que he escrit sobre com obtenir quad estèreo tamponada per treballar amb el famós simulador de vol FlightGear. Recentment FlightGear-2.4.0 ha estat alliberat. El problema amb quad estèreo tamponada persisteix amb FlightGear-2.4.0.

Un espera per habilitar la manera estereoscòpic en FlightGear començant amb la següent línia:

OSG_STEREO_MODE exportació = QUAD_BUFFER; exportació OSG_STEREO = ON; fgfs

En iniciar FlightGear aquesta manera, s'obté la següent sortida de la consola i sense visió estereoscòpica:

Són els detectat error OpenGL "operació no vàlida" després RenderBin :: empat (,)

Aconseguir FlightGear per treballar amb equip de música amb memòria intermèdia cuadrafónico

La raó per al missatge d'error anterior i la manera estèreo trencat resultant és, que el context estèreo no aconsegueix inicialitzat correctament. Els detalls es descriuen a continuació: FlightGear amb quad tamponada estèreo. No obstant això, la bona notícia és, que el pegat que vaig proposar en el post esmentat, encara treballa amb FlightGear-2.4.0. Podeu descarregar el pegat des d'aquí: FlightGear-2.0.0-stereoscopic.patch (969)

Com és habitual en quad tamponada estèreo, vostè ha d'utilitzar una targeta gràfica professional que suporta quad tamponada estèreo, com una NVIDIA Quadro FX o ATI FireGL i maquinari correcta visualització, com ulleres d'obturació, 1 HMD o un sistema de projecció estereoscòpica, per beneficiar- ella. Per utilitzar el quad tamponada manera estèreo inici FlightGear amb les variables d'entorn abans esmentades. Després és probable que hagi d'activar el mode estèreo de quatre buffers seleccionant la estereoscòpica Veure les opcions d'articles al menú de la vista.

Amb la versió anterior, quan s'utilitza el mode estèreo quàdruple memòria intermèdia a FlightGear, es va produir alguns errors gràfics. Alguns controls de la cabina i altres detalls de l'escena contenien línies grogues, com un filferro, que no hi eren quan s'inicia FlightGear en mode de visualització "normal". Aquests problemes semblen haver desaparegut amb FlightGear-2.4.0. Almenys jo no em vaig adonar d'ells mai més.

La forma en Gentoo

Per als usuaris de Gentoo He creat una superposició. Igual que l'anterior que conté pegats i ebuilds modificats per FlightGear amb el suport de memòria intermèdia quàdruple de treball. Vostè pot obtenir la superposició d'aquí: FlightGear-2.4.0 superposició (553) Descarregar la plantilla i extreure'l en / usr / local / portage. Assegureu-vos d'incloure la següent línia en el seu /etc/make.conf:

PORTDIR_OVERLAY = "/ usr / local / portage"

Llavors sorgirà FlightGear i gaudir-ne en tres dimensions.

Diverteix-te

Jürgen

1 Star2 Stars3 Stars4 Stars5 Stars (1 vots, mitjana: 5.00 de 5)
Loading... Carregant ...

estereoscòpica mplayer-1.0_rc4_p20110322

Ahir el nou ebuild mplayer-1.0_rc4_p20110322 va aparèixer en portage. En el post mplayer estereoscòpica a treballar de nou part 2 vaig proporcionar un pegat modificat pel suport estereoscòpica en mplayer-1.0_rc4_p20101114. Aquest pegat encara funciona amb la versió actual. Per utilitzar-lo, només ha de descarregar el pegat des d'allà, amb còpia a:

/etc/portage/patches/media-video/mplayer-1.0_rc4_p20110322-r1/

emergir després mplayer i reproduir pel·lícules estereoscòpiques amb

mplayer -vo GL2: some_movie_file.avi estèreo

Mithrandir

1 Star2 Stars3 Stars4 Stars5 Stars (1 vots, mitjana: 5.00 de 5)
Loading... Carregant ...
09/10/2011

info mygnu

el blog rotllo

Informació del lloc

Trans lador

English flagItalian flagKorean flagChinese (Simplified) flagChinese (Traditional) flagPortuguese flagGerman flagFrench flag
Spanish flagJapanese flagArabic flagRussian flagGreek flagDutch flagBulgarian flagCzech flag
Croatian flagDanish flagFinnish flagHindi flagPolish flagRomanian flagSwedish flagNorwegian flag
Catalan flagFilipino flagHebrew flagIndonesian flagLatvian flagLithuanian flagSerbian flagSlovak flag
Slovenian flagUkrainian flagVietnamese flag